Switch Cisco

Administrer par le port console

L'administration par port console utilise les paramètres suivants :

  • Bits de données : 8 bits
  • Bit stop = 1 bit
  • Bit de parité : aucun (none)
  • Contrôle de flux de données : XON/XOFF
  • Débit : 9600 bits/s

Mode d'accès

Une fois établie la connexion avec le switch (par le réseau ou le câble console), on tombe sur le niveau sans privilèges qui permet quelques manipulations de diagnostic.

switch> 

On passera dans le mode privilège grâce à la commande enable de manière à pouvoir réaliser la sauvegarde notamment.

switch> enable
switch#

On pourra passer en mode configuration pour réaliser le paramétrage du switch

conf t

Réinitialiser le switch

La réinitialisation passe par un appui long sur le bouton en façade.

Si on a accès à la console, on peut aussi utiliser la syntaxe

write erase

Visualiser la configuration

On peut connaître de multiples éléments de la configuration. On utilise la commande show depuis le niveau mode privilège.

Voir l'ensemble du paramétrage

sho run

Voir la configuration des vlan

sho vlan

Voir le paramétrage ip

sho ip interface

Accès aux interfaces

Les interfaces sont nommées fa0/<n°_interface> (ethernet 100 Mbps) et gi0/<n°_interface> (ethernet 1 Gbps).

L'accès à une interface s'écrit

interface fastethernet<N°_interface>

ou

interface gigabit <N°_interface>

Remarque : s'il y a plusieurs modules d'interface, fa0/x peut-être décliné en fa1/x, etc.

L'accès à une plage d'adresse s'écrit :

 interface range fa0/<n°départ>-<n°fin> 

Créer un VLAN

La création de VLAN se passe en deux temps :

  • Déclarer le vlan
  • Le paramétrer et l'activer

Déclarer un VLAN

vlan <n°_vlan>

Paramétrer le VLAN

interface vlan <n°_vlan>
name <nom_du_vlan>

Mettre un port dans un VLAN

interface <numero_interface>
switchport mode access
switchport access vlan <n°_vlan>

Mettre un port en 802.1Q

interface <numero_interface>
<code lscript>switchport mode trunk
switchport trunk allowed vlan add <n°_vlan>
switchport trunk allowed vlan all

Définir le paramétrage adresse IP

Pour l'administrer à distance, il faudra disposer d'un port dans le VLAN ou que le VLAN passe dans un port en 802.1Q.

Les switch de niveau 2 n'ont qu'une adresse IP, celle qui permet de l'administrer à distance. Il faut affecter une IP à un VLAN.

interface vlan <N°_vlan>
ip address <ip> <masque>
ip default-gateway <ip_passerelle>

Activer l'accès distant

Accès par interface Web

On peut activer l'accès à l'interface Web en 3 étapes :

  1. activer le service
  2. préciser le mode d'authentification
  3. créer un utilisateur avec les privilèges
(config)# http server
(config)#http authentication local 
(config)#ip http port <numero_port> //option possible 
(config)#username <nom_user> privilege 15 password 0 <mot_passe>

Accès Telnet

L'accès Telnet nécessite la définition d'un mot de passe pour le passage en mode enable :

#enable password <mot_passe>
//ou
#enable secret <niveau_privilege> <mot_passe>

On peut ensuite accorder la connexion distante :

#line vty 0 4  //les valeurs numériques correspondent au niveau de privilège
password <mot_passe_telnet>
login

Sauvegarder la configuration

Un switch utilise la mémoire vive pour son paramétrage. Il est nécessaire d'inscrire les modifications dans la mémoire permanente pour les retrouver suite à une coupure électrique. Cette sauvegarde se fait depuis le mode privilège (sortir du mode config).

Sauvegarde locale

Pour inscrire la configuration de manière permanente dans le switch, on utilisera la commande :

copy running-config startup-config

Sauvegarde distante

On peut aussi faire une copie de la configuration sur un serveur tftp distant

copy running-config tftp://<ip_serveur>/<nom_fichier>

Il sera aussi possible de restaurer cette configuration sur un switch (paramétré avec une adresse IP).

copy tftp://<ip_serveur>/<nom_fichier> running-config

Configurer le Spanning Tree

Dans la copie d'écran suivante le switch est root pour les vlans 1 à 100. Puis on affiche les données spanning-tree pour le vlan 4.

switch(config)#spanning-tree vlan 1-100 root primary
switch(config)#end
switch#show spanning-tree vlan 4
 
VLAN04
Spanning tree enabled protocol rstp
Root ID Priority 24726
Address 0026.525b.3500
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
 
Bridge ID Priority 24726 (priority 24576 sys-id-ext 4)
Address 0026.525b.3500
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec
 
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/3 Desg FWD 19 128.3 P2p
Gi0/1 Desg FWD 19 128.9 P2p
 
 
switch#

Dans l'exemple, l'interface prioritaire sera gi0/1 pour les vlans 1 à 100.

switch(config)#interface gigabitEthernet 0/1
switch(config-if)#spanning-tree vlan 1-100 port-priority 64
switch(config-if)#end

Afficher la configuration des vlan

Pour afficher la configuration il suffit de taper la commande suivante

switch#show spanning-tree vlan 4

Configurer le SNMP

La configuration de SNMP consiste à définir la communauté et les droits d'accès associés.

snmp-server community <nom_communauté> <droits> 

Les droits sont :

  • RO : Lecture seule, permet de lire les informations
  • RW : Lecture/écriture, permet d'affecter des paramétrages via SNMP

Mirorring de port

Il est possible de renvoyer le trafic de certains ports vers un port destination, pour éffectuer du monitoring (détection d'intrusion, métrologie, etc). On définit :

  • la source : les ports dont on veut relever le trafic
  • la destination : le port vers lequel on recopie le trafic
#monitor session <numero_session> source interface <liste_ports>
#monitor session <numero_session> destination interface <port_miroir>
  • le <numero_session> permet d'effectuer plusieurs renvois. il doit être identique entre les deux lignes
  • la <liste_ports> est une combinaison de ports et range séparés par des virgules (exemple : Gi1/0/1 - 3 , Gi1/0/5 - 22, Gi1/0/24)

Sources complète et détaillée

Pour avoir la documentation complète et détaillée aller sur ce lien : https://www.clemanet.com/spanning-tree.php#haut